Back to overview
Downtime
API Service unavailabe due to upstream provider outage
May 01 at 02:26pm GMT+8
Affected services
api.buycheap.ai
Resolved
May 01 at 02:41pm GMT+8
All services resume normal operation
Affected services
api.buycheap.ai
Created
May 01 at 02:26pm GMT+8
Southeast Asia (asia-southeast1 / Singapore) experiencing partial outage. Fix is rolling out.
Affected services
api.buycheap.ai